10 major freeCodeCamp improvements that are live now

10 major freeCodeCamp improvements that are live now
0

#413

Just an FYI, you may know already, but a link within one of the curriculum pages (Basic JavaScript: Assignment with a Returned Value) has a broken link. I can get to it if I go to the curriculum tab & click the link there, but not within that page. I tried a few other pages with internal links, but they seem to be working fine. I just wanted to let you know about that one, in case you didn’t already know about it. I know you all are working hard on updating everything already though. Thanks. (BTW, I’m lovin’ the new updates!) :star_struck::sunglasses::bug::butterfly::lollipop:


#414

Hi, every time I try to run the tests to pass a challenge, I click run tests and then it says running test and doesn’t do anything. I’m not sure if it is a bug or just my slower computer but it is really annoying. I am not sure if I posted this in the right place but I think it might be related to the improvements so that’s why I posted it here.


#415

Are you by any chance using Edge, IE, or Safari as your browser? These have decided not to implement new features of JS and CSS according to web standards and as a result they often exhibit unintended (and frustrating) behavior.


#416

Oh, I’m using Edge. Do you know if it works with Firefox or Chromium?


#417

I believe so. There are still some bugs, of course, but life will be much easier if you don’t use Edge.


#418

Thanks!!! (Sorry I needed 20 characters)


#419

Yeah, I know that, thanks. The in-editor code being saved is fine, but when I download my user data from the settings page, it only has two challenges’ solutions, even though I’ve done a hundred, or so. Is my data lost forever, or am I just not being shown it?


#420

Just a quick question ; I am still unable to print out my Back End certification even though I have done all of the required projects.

Is this still an ongoing issue ?


#421

@Aviage-01 - Based on what I’ve observed on GitHub, only the project solutions are being stored, but there is work being done to add a button to download your solution when you complete a lesson.

@BoCode84 - I know that a GitHub Issue was created for this. You can do a search and subscribe to updates. If no one is working on it yet, you could submit the fix.


#422

Great work. I just returned to freecodecamp after a long time. The new curriculum looks good, and thanks for including new standards and practises for CSS and Javascript as well.


#423

@ArielLeslie

I have seen the thread opened for this issue.
All I need is just an image so I have an official certificate in case if employer asks for it.
That’s all.
Is there any way we can receive it ?
Maybe @QuincyLarson would know more about this ?


#424

If you look at the GitHub Issue, you’ll see that

  1. Printing works in Firefox
  2. You can take a screenshot and print that
  3. A fix has been made and is currently in staging.

#425

Will check later today

Thank you !


#426

So in other words, all the work done on the lessons is gone forever?
I’m depressed.


#427

They’re just learning exercises. They weren’t anything that you had really built yet. Now that you’ve proceeded past them, you have the skills and experience to be able to do those small tasks again, probably better. Being depressed about not having your old answers is like being depressed about not having old math homework.


#428

Yes, I still have the skills gained from those challenges, but those challenges were a library that I had built up.
For instance, some of the code I made later on needed a falsy-bouncer-type function, which, because the original falsy bouncer I made was gone forever, meant I had to re-code it.
So it’s like being depressed that the math cheat-sheets you had made in your math homework had been destroyed. Or that the problems you were facing were the same ones as in your math homework, but because the homework had been destroyed, you had to work out the problems again.


#429

@ArielLeslie

I have tried Firefox and it is still not working

Error I am getting is “it looks like you have not completed the necessary steps. Please complete the required challenges to claim the APIs and Microservices” ; yet, I have completed all projects required and it is allowing me to click on “Claim certification”

Could you, please, let me know what I have done incorrectly ?


#430

I thought that you were complaining about not being able to print. Printing works in Firefox. There is a different issue regarding claiming that certificate. You can monitor its status on GitHub.


#431

Well ; printing as in getting it to show as image ; That’s what I meant ; Sorry if I was not clear.


#432

i just completed my html projects,but not able to access my certificate please help me out . On homepage ot shows that you have earned but i am not able to see it.