Backend: Issues with Node JS/chrome

Backend: Issues with Node JS/chrome
0

Tell us what’s happening:

Hi all,

Relatively new to backend development and have been trying to set up a blog app with mongoDB and Node with Express in a local environment on Windows.

Using Git terminal, I can run the DB with no problems and, using Mongo shell, see the collections and individual posts in the DB. I can start my app.js file with Node and see that the server connects to the DB just fine.

When I try to display the app using the localhost URL, chrome will not display the webpage even though the server is running with node.

In previous days everything has been working fine, just today when I try to display the blog in the browser, the browser loads and never displays it.

Any help/advice is appreciated. Thanks.

What error message do you get in the browser? Perhaps try restarting the node server, or try changing the port if that doesn’t work.

I don’t get an error in the browser, it just continues to load without ever displaying the webpage.

I tried restarting the server and changing the port for app.listen, neither have worked :confused:

Try creating a new boilerplate project and see if that works. If it does you know there’s a problem in your project somewhere.

Yup, for a different project using Mongo DB and Node JS with express, when the server is running on port 3000 I can view my template files in the browser just fine.

It’s just for this one blog app that I can’t display web pages in the browser, and no errors are given. Not sure how to find the problem.