Basic Node and Express - Meet the Node console

Basic Node and Express - Meet the Node console

I was having problems with this challenge as well but was able to pass the tests after reading this thread.

While I was writing down my solution I found that I still could not identify the problem.
The first time I visited the link to Glitch(!/import/github/freeCodeCamp/boilerplate-express/) from the introduction page(, I landed on a project page that did not have a myApp.js file. After I found this thread and visited the link provided by @zdflower I landed on a project page that had a myApp.js file. I checked the URL’s for both links and they are the same. Maybe there is a problem with Glitch?

Additionally, I signed up for a Glitch account after visiting the link to the project the first time and had to visit it a second time to start coding. Maybe there was a problem with something cache/cookie related? I’m not sure what the problem is, but if the Glitch link you follow doesn’t have a myApp.js file, try another browser or clearing your cache and let us know if you’re still having an issue.


if you had troubles with this issue, you can try to write the code in myApp.js as the image showed, I used this way to pass the test. Good luck~~~


Guys, I belive I know the issue - the most probably you are trying to code within the previous project - where you had been working during the previous section “Introduction to Managing Packages” or any else. You must follow the link provided by this manual and that open you the proper one with “myApp.js” file inside. I had the same issue until I opened a new project in this block.


I have the same issue, (’“Hello World” is not in the server console’) even though I have written the exact same code in the exact same spot as ccrubby214. There seems to be no way to save the code in Glitch, so I can’t be confident that the code I’ve written is the code being tested. I haven’t done any previous projects in Glitch so that won’t have anything to do with it. I also tried ‘remixing’ the project to be sure that I am coding in my own user account and still having issues.

Thanks Milyaniko, I had the same issue and couldnt figure out what was wrong. Yeah, was working on the wrong boilerplate.

On the left side of the PAGE:
Next to your profile image is a button called ‘Share’
click open and Copy the link under APP


This is the solution that worked for me :slight_smile: Thanks Alex!

This worked for sure. Clicking on the link starts a new project.

I would just like to say that the instructions for this challenge are as clear as mud!
I can’t believe it is this difficult to set up. Perhaps this is part of the challenge!

This solved my issue with not seeing myApp.js. I was working in the previous project. I selected the new link and it worked perfectly.

Thank you! @Milyaniko

The exercise is bugged. i try it all ways but didn’t work.

If you are doing the exact same thing that ccrubby214, and with this I mean putting the console.log under the “1) Meet the node console”, maybe you are putting the wrong URL just like I was doing

Putting didn’t work for me, but putting worked just fine

Is this what we are supposed to do???

I’m still having the same problem. No matter which link I use I’m not able to find a project with the myApp.js file.

1 Like

That’s it. Thank you.

Hello , i found a solution that works fine !

Dont use the glitch link but the github link . In the github link , you will find a myApp.js (yes surely :blush:)

after , create a myApp.js file on your glitch project and paste the content of the Github’s link myApp.js to the new created myApp.js file (myApp.js of Glitch). do the same with server.js and package.json

write your code in myApp.js instead of server.js then you can pass the challenge. :laughing:

Thanks @zdflower. I’ve somehow found many different boilerplate from multiple pages. YOURS is the one that worked!

I found this very confusing but I got the issue. You (we) have to open a new Glitch project for this episode. We should not use the same as the previous one. The new one is:!/import/github/freeCodeCamp/boilerplate-express/

You can check the link on this episode;

The previous episode’s glitch is different:!/import/github/freeCodeCamp/boilerplate-npm

You may check it on the previous episode:

This worked fine. And yes, I was using the wrong boilerplate.

I am still having trouble importing the github repo into Glitch. There occurs an error message that something went wrong, while the import takes place. The project structure is shown on that step but then the files disappear and are not available any longer, because the page automatically reloads itself.

Is there someone, who faces the same problems?