Build a Product Landing Page - Links error

Build a Product Landing Page - Links error
0
#1

Tell us what’s happening:
I get an error message that my 2020 Reunion link is not working … but it does?

          <li><a class="nav-link" href="#2020reunion ">2020 reunion</a></li>``

```2020 reunion section - <h3>2020 Reunion</h3>

            <div class="2020 Reunion" id="2020reunion">
              <ul>Robinson Reunion 2020</ul>
              <li>July 21 through July 26, 2020</li>
              <li>Little Rock, Arkansas</li>
              </p>
           
            </div>``



**Your code so far**

**Your browser information:**
https://codepen.io/diane-nelson-trotter/pen/zQzPJZ?editors=1100
User Agent is: <code>Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.157 Safari/537.36</code>.

**Link to the challenge:**
https://learn.freecodecamp.org/responsive-web-design/responsive-web-design-projects/build-a-product-landing-page
#2

Can you post a link to your demo?

#3

https://codepen.io/diane-nelson-trotter/pen/zQzPJZ

I’m sorry I forgot to include link.

#4

Are you talking a bout a freecodecamp error? Can you include a test suite?

#5
  1. When I click a .nav-link button in the nav element, I am taken to the corresponding section of the landing page.’
    The .nav-link with href="#2020reunion " is not linked to a corresponding element on the page : expected null to not equal null
    AssertionError: The .nav-link with href="#2020reunion " is not linked to a corresponding element on the page : expected null to not equal null
    at s.l (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:262:1134)
    at s.e. [as equal] (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:325:126)
    at Function.n.isNotNull (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:224:1253)
    at https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:154:50377
    at NodeList.forEach ()
    at r. (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:154:50184)
    at c (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:159:31608)
    at o.f.run (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:159:31544)
    at m.runTest (https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:159:37114)
    at https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js:159:37976
#6

@dianetrotter throughout your navbar you have code such as;
<li class="active "><a href="#home ">Home</a>

all I did on your page (but didn’t save it of course) is remove that whitespace so they look like;
<li class="active"><a href="#home">Home</a>

Had to do all of them because if one was corrected the test would fail for the next. Once all were clean, the test passed.

#7

remove <li class="active"><a href="#home">Home</a>

#8

I think there is something wrong with the programming. I have removed the space between the word and quotation mark at least 100 times. I go back over the same ones all the time. I quickly save and it seems to be ok. Then a while later I’m right back to the white space.

Thank you!