Error message keep popping out when using terminal

Error message keep popping out when using terminal
0

#1

Whenever I use terminal to do a certain task, for example,
brew cask install vscodium or bundle show minima (jekyll)
my terminal keeps telling me this:

Ignoring commonmarker-0.17.13 because its extensions are not built. Try: gem pristine commonmarker --version 0.17.13

What do I need to update to get rid of this error message?


#2

Just to be sure, do you already have brew installed? (https://brew.sh/)


#3

yes.
30%20AM

also here are some of the stuff I tried but failed.


#4

and have you tried using the alternate installation method?

Add this line to your application’s Gemfile:

gem 'commonmarker'

And then execute:

$ bundle

#5

I think it worked.

Here is the message I got:

Installing commonmarker 0.17.13 with native extensions
cp: /usr/bin/commonmarker: Operation not permitted
Using eventmachine 1.2.7
Using http_parser.rb 0.6.0
Using em-websocket 0.5.1
Using ffi 1.9.25
Using forwardable-extended 2.6.0
Using rb-fsevent 0.10.3
Using rb-inotify 0.9.10
Using sass-listen 4.0.0
Using sass 3.6.0
Using jekyll-sass-converter 1.5.2
Using ruby_dep 1.5.0
Using listen 3.1.5
Using jekyll-watch 2.0.0
Using kramdown 1.17.0
Using liquid 4.0.0
Using mercenary 0.3.6
Using pathutil 0.16.1
Using rouge 3.3.0
Using safe_yaml 1.0.4
Using jekyll 3.8.4
Using jekyll-feed 0.11.0
Using jekyll-seo-tag 2.5.0
Using minima 2.5.0
Bundle complete! 5 Gemfile dependencies, 31 gems now installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.
➜  slowpacedcoding git:(gh-pages) ✗ bundle info [commonmarker]
zsh: no matches found: [commonmarker]
➜  slowpacedcoding git:(gh-pages) ✗ bundle info commonmarker
  * commonmarker (0.17.13)
	Summary: CommonMark parser and renderer. Written in C, wrapped in Ruby.
	Homepage: http://github.com/gjtorikian/commonmarker
	Path: /Library/Ruby/Gems/2.3.0/gems/commonmarker-0.17.13
➜  slowpacedcoding git:(gh-pages) ✗