freeCodeCamp 2018 JAMstack Hackathon at GitHub in San Francisco on November 3 - 4

freeCodeCamp 2018 JAMstack Hackathon at GitHub in San Francisco on November 3 - 4
0

#41

Hi @QuincyLarson @AnnabelleSP,
I am stuck in #5.
I even tried to run the command in new terminal window as in Gatsby.js says but have the same result.

After running the command have this message:
In between the lines there are more info lines in lighter color.

my Node.js version is 8.9.4
my NPM version is 5.6.0

by the way in the earlier step since I am using Window OS(Win7) I tried without the ‘sudo’ key word and got through the stage, the program did not asked for any system password.
Maybe should update the tutorial on that.
Thank you for the reassurance for the step @AnnabelleSP :slight_smile:

Thanks for any help


#42

Hello mate , @ItsikDangoor

i came to know that it is not mandatory to use a WSL… so I shifted to Git Bash…and all went fine for me…


#43

I am stuck at step 12…

can anyone help me plzz…

what i understood is…we should add the jamstack-hello-world repository to the gatsby folder…am i right?’


#44

Hi @QuincyLarson @AnnabelleSP and All,
I got the issue handled BUT…

The issue was that I do not have a premission in the library I currently in!
in one immage I am presenting the command result and the NPM upgrade(new users can only upload one image here).
So what I did:

  • cd ~ went out the library I currently were
  • mkdir gatsby-site, created the library
  • cd gatsby-site, went inside
  • gatsby new gatsby-site, run the program

after that upgrade NPM:
Do as the message recommended, I upgraded NPM version, two commands…

My questions:
The npm audit result message, with this report can I continue the the next steps?

Thank you very much.


#45

Hello mate @vamsikrishnareddybev,

Happy for you.
What is WSL?


#46

WSL IS WINDOWS SUB SYSTEM FOR LINUX …which the fcc article recommended to work on…


#47

Have you done cd gatsby-site && gatsby develop ? Because I checked your cmd and found out that you missed out the command.

I double-checked your command, you should use gatsby develop to run it instead of gatsby new-gatsby-site


#48

I encounter the same situation as yours when I try to do it again. But I ignore it and proceed with the next command cd gatsby-site && gatsby develop and it works well :slight_smile:


#49

Thank you @AnnabelleSP, I am on the next steps now.

Cheers


#50

Thank you all for the help @AnnabelleSP @vamsikrishnareddybev.
I finished the process and applied.

Hope to see you and meet good people on Hackathon Online.
Have fun in weekend.
Excited :sunny: :sunglasses::vulcan_salute:


#51

@ItsikDangoor

bro…

i am stuck at step 12 …plzz help me…


#52

Hi @vamsikrishnareddybev,
you don’t need to add the jamstack-hello-world repository to the gatsby folder, It is the opposite.
By the order of the steps you first create the app see if it’s run on your browser, after that you create the repository and commit the files from your local storage-computer to the Git (step #8), still not out there in the web it’s still in your local computer, it a commit(like creating a record).
In the next steps you create GitHub account and repository in GitHub and push your code to GitHub.

Have you done all the processes in order?
What error messages you get, if any?
Have you created the repository in GitHub?
Do you see the repository on GitHub?
In what screen exactly are you now?
Can you add screenshots?

Please give us more info that we understand more and help.

Cheers


#53

just wanted the thread to be in order
Thanks @vamsikrishnareddybev


#54

bro…

i added ssh key
and created a github repo

i did not understood…step 12?


#55

bro…

what exactly…does…step 12 means?


#56

Once you hit create repository button in the previous step, you will be led to step #12.

It’s basically saying that you have a local git repository but you need to link it to your remote repository that you just created in github.


#57

Are you inside the project’s directory and running the remote add & push commands?

@shimphillip said it right.


#58

Run this first. I did this and it installed npm and then I could run the command you are trying to run now.
How this helps!

sudo apt-get install npm


#59

Hi @QuincyLarson,
I submitted the form and did not get any email confirmation that my form submision received.
Is my submmision did not pass the communication or something?
Did anyone got any email confirmation for submitting the registration form?

Thank you


#60

Wow. This looks like an awesome Technology. I embedded my EdHub app just for fun :smile:

Here is my Submission link:
https://julius.netlify.com

~ Julius :blush: