freeCodeCamp Beta map drop-down menus not working!

freeCodeCamp Beta map drop-down menus not working!
0

#1

Hello!

So now I want to start playing with FCC Beta. But it seems that I can’t open the map’s drop-down menus (Responsive Web Design; Javascript Algorithms And Data Structures; Front End Libraries; etc.) for some obscure reason - they just don’t unroll when I click on them!

Also, when I’m on Learn how Freecodecamp works and click on Finish challenge, I get this message on the bottom right of the page: Something went wrong, please try again later.

I tried on Chrome and on Safari - same problem!

So I’ve been stuck here for a while now. Does any generous soul have a solution to this problem?

Thanks!


#2

It’s a known issue. I made a thread here asking for any info that might help to debug it: Something Went Wrong?

If you’re just starting, you’re better off with the version of the site that is currently live.


#3

Yes I saw your thread earlier @r1chard5mith, but are the two problems I mentioned related?


#4

Well, does it say ‘something went wrong’?. Anyway, good luck!


#5

As I mentioned, my main problem is that the map’s drop-down menu does not unroll when I click on it and it does not show any error message.
This issue doesn’t seem to be mentioned anywhere.

But thanks, anyway!


#6

Hey I noticed this when I wanted to just have a look at the site and material the other day/week.

There seems to be something weird happening where when you first go the the page it tries to redirect when you click on the dropdown e.g. “https://beta.freecodecamp.org/en/challenges/basic-html-and-html5/learn-how-freecodecamp-works#Responsive Web Design” (adding on the #map name to the url). I waited a couple of mins and then the page worked. If I then open up a new page and navigate to the map again it works as intended (no reloading/url change).

Does this happen for you as well?


#7

Interesting! I inspected the element and normally it should redirect you to the link you provided, so it’s not weird I suppose!
I tried your method, but it still doesn’t work for me!


#8

hmmm sorry, I’m not sure then. I don’t know where to start, perhaps open an issue on the beta github and try to describe it as best as possible.