freeCodeCamp Challenge Guide: Nest an Anchor Element within a Paragraph

freeCodeCamp Challenge Guide: Nest an Anchor Element within a Paragraph


Nesting is simple, just add one element inside another:

<p> click here for <a href="">cat photos</a></p>

How do I pass this exercise?

I can't seem to move beyond this point, even though I have followed the steps as instructed.

Any help would be greatly appreciated!

Nest an Anchor Element within a Paragraph1

@robt90 It looks you put a space at the beginning of you p element. Try without! :wink:


Yep, tried that out and it works perfectly! Thanks for the help :slight_smile:

.red-text { color: red; }

h2 {
font-family: Lobster, Monospace;

p {
font-size: 16px;
font-family: Monospace;

.thick-green-border {
border-color: green;
border-width: 10px;
border-style: solid;
border-radius: 50%;

.smaller-image {
width: 100px;


View more cat photos

A cute orange cat lying on its back.

Kitty ipsum dolor sit amet, shed everywhere shed everywhere stretching attack your ankles chase the red dot, hairball run catnip eat the grass sniff.

Purr jump eat the grass rip the couch scratched sunbathe, shed everywhere rip the couch sleep in the sink fluffy fur catnip scratched.


I can’t seem to get past this task. My code seems fine:

View more cat photos

I still can’t run it. Any help would be appreciated. Thanks!


Hi all - I cannot figure out what I am doing wrong here…help!


Hey Everyone,

I’m really struggling here too, can anyone help?


I just figured it out after a frustrating 30min,
the code was right it was just in the wrong place. Reset the code and then put your begining p element with the “View more” above the anchored element then enclose it below.

normal beginning p element "View more"
anchored element that is there already
enclose the p element

sorry if I confused you. hope it helps


Could you possibly post your code? I tried a few different ways and no luck. Any help is appreciated



the same happened to me, I had the code right, but did not let me advance, the only thing I did was to go out and re-enter


This does not work for me :sob:


I have the same problem :cry: tried several methods. Please help me


@Muhu6 It may have timed out like @gaboleo91 said try to log out, Clear the code, then try again. I just cleared mine and it’s posted below step by step:




I had the same issue where it was coded right but not taking it. It was fixed after i reset the code and cleared my cache. Worked the first time after doing that.


Thanks. That worked after trying for long hours to figure out what went wrong.


Absolutely, glad I could help.