Installation error

Installation error
0

When I tried running npm run develop I got this error

> @freecodecamp/freecodecamp@0.0.1 develop C:\Users\USER\Downloads\freeCodeCamp
> npm-run-all ensure-env -p develop:*


> @freecodecamp/freecodecamp@0.0.1 ensure-env C:\Users\USER\Downloads\freeCodeCamp
> cross-env DEBUG=fcc:* node ./tools/scripts/build/ensure-env.js

  fcc:tools:ensure-env ignoring creation of redirect file in undefined +0ms
  fcc:tools:ensure-env pathMigration present +6ms

> @freecodecamp/freecodecamp@0.0.1 develop:client C:\Users\USER\Downloads\freeCodeCamp
> cd ./client && npm run develop


> @freecodecamp/freecodecamp@0.0.1 develop:server C:\Users\USER\Downloads\freeCodeCamp
> cd ./api-server && npm run develop


> @freecodecamp/api-server@0.0.1 develop C:\Users\USER\Downloads\freeCodeCamp\api-server
> cross-env DEBUG=fcc* node development-start.js


> @freecodecamp/client@1.0.0 predevelop C:\Users\USER\Downloads\freeCodeCamp\client
> npm run prebuild


> @freecodecamp/client@1.0.0 prebuild C:\Users\USER\Downloads\freeCodeCamp\client
> npm run build:workers && node ../tools/scripts/build/ensure-env.js

Debugger listening on ws://0.0.0.0:9229/4fcb1b2d-f4ee-490b-94ce-3c40c8e00fc1
For help, see: https://nodejs.org/en/docs/inspector

> @freecodecamp/client@1.0.0 build:workers C:\Users\USER\Downloads\freeCodeCamp\client
> node --max_old_space_size=7168 node_modules/webpack-cli --env.production --config ./webpack-workers.js --progress

 10% building 0/3 modules 3 active ...nt\src\client\workers\test-evaluator.jsBrowserslist: caniuse-lite is outdated. Please run next command `npm update`
  fcc:server:datasources using MailHog server on port 1025 +0msules\lodash\noop.js
 93% after chunk asset optimization SourceMapDevToolPlugin vendors~enzyme~enzyme-adapter.js generate SourceMap  fcc:server:utils:about no google applications credentials environmental variable found
  fcc:server:utils:about 'GOOGLE_APPLICATION_CREDENTIALS'
  fcc:server:utils:about 'activeUser' api will always return 0
  fcc:server:utils:about this can safely be ignored during development +2s
  fcc:models:user setting up user hooks +200ms
 93% after chunk asset optimization SourceMapDevToolPlugin frame-runner.js generate SourceMap  fcc:server freeCodeCamp server listening on port 3000 in development +708ms
  fcc:server connecting to db at mongodb://localhost:27017/freecodecamp +1ms
Hash: a684b07b1183774576da
Version: webpack 4.28.4
Time: 8665ms
Built at: 05/07/2020 3:07:10 AM
                               Asset       Size  Chunks                    Chunk Names
                   enzyme-adapter.js  185 bytes    2, 1  [emitted]         enzyme-adapter
               enzyme-adapter.js.map   94 bytes    2, 1  [emitted]         enzyme-adapter
                           enzyme.js  177 bytes    1, 2  [emitted]         enzyme
                       enzyme.js.map   86 bytes    1, 2  [emitted]         enzyme
                     frame-runner.js    186 KiB       3  [emitted]         frame-runner
                 frame-runner.js.map    886 KiB       3  [emitted]         frame-runner
                     sass-compile.js   1.33 KiB       4  [emitted]         sass-compile
                 sass-compile.js.map   5.76 KiB       4  [emitted]         sass-compile
                        sass.sync.js   4.27 MiB          [emitted]  [big]
                   test-evaluator.js    166 KiB    5, 6  [emitted]         test-evaluator
               test-evaluator.js.map    869 KiB    5, 6  [emitted]         test-evaluator
                     vendors~chai.js   67.8 KiB       6  [emitted]         vendors~chai
                 vendors~chai.js.map    419 KiB       6  [emitted]         vendors~chai
           vendors~enzyme-adapter.js    237 KiB       7  [emitted]         vendors~enzyme-adapter
       vendors~enzyme-adapter.js.map    784 KiB       7  [emitted]         vendors~enzyme-adapter
    vendors~enzyme~enzyme-adapter.js    533 KiB       0  [emitted]  [big]  vendors~enzyme~enzyme-adapter
vendors~enzyme~enzyme-adapter.js.map   2.09 MiB       0  [emitted]         vendors~enzyme~enzyme-adapter
Entrypoint frame-runner = frame-runner.js frame-runner.js.map
Entrypoint sass-compile = sass-compile.js sass-compile.js.map
Entrypoint test-evaluator = test-evaluator.js test-evaluator.js.map
[322] (webpack)/buildin/global.js 472 bytes {0} {5} {6} [built]
      ModuleConcatenation bailout: Module is not an ECMAScript module
[365] ./src/client/frame-runner.js 5.13 KiB {3} [built]
      ModuleConcatenation bailout: Module uses eval()
[369] ./src/client/workers/sass-compile.js 756 bytes {4} [built]
      ModuleConcatenation bailout: Module is not an ECMAScript module
[370] ./src/client/workers/test-evaluator.js 3.7 KiB {5} [built]
      ModuleConcatenation bailout: Module uses eval()
[396] (webpack)/buildin/module.js 497 bytes {0} [built]
      ModuleConcatenation bailout: Module is not an ECMAScript module
[482] readable-stream (ignored) 15 bytes {1} {2} [built]
      ModuleConcatenation bailout: Module is not an ECMAScript module
[491] util (ignored) 15 bytes {1} {2} [built]
      ModuleConcatenation bailout: Module is not an ECMAScript module
[492] util (ignored) 15 bytes {1} {2} [built]
      ModuleConcatenation bailout: Module is not an ECMAScript module
[557] ./util.inspect (ignored) 15 bytes {1} {2} [built]
      ModuleConcatenation bailout: Module is not an ECMAScript module
    + 801 hidden modules

WARNING in asset size limit: The following asset(s) exceed the recommended size limit (244 KiB).
This can impact web performance.
Assets:
  vendors~enzyme~enzyme-adapter.js (533 KiB)
  sass.sync.js (4.27 MiB)

> @freecodecamp/client@1.0.0 develop C:\Users\USER\Downloads\freeCodeCamp\client
> node --inspect=0.0.0.0:9228 node_modules/gatsby-cli develop

Debugger listening on ws://0.0.0.0:9228/f57acc09-5ca6-4709-8e2c-b12dc3975209
For help, see: https://nodejs.org/en/docs/inspector
  fcc:server db connected +2s
  fcc:boot:donate activeDonator count: 0 +2s
success open and validate gatsby-configs - 0.383 s

Something went wrong installing the "sharp" module

Cannot find module '../build/Release/sharp.node'
Require stack:
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\sharp\lib\constructor.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\sharp\lib\index.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby-plugin-manifest\safe-sharp.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby-plugin-manifest\gatsby-node.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby\dist\bootstrap\resolve-module-exports.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby\dist\bootstrap\load-plugins\validate.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby\dist\bootstrap\load-plugins\load.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby\dist\bootstrap\load-plugins\index.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby\dist\bootstrap\index.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby\dist\commands\develop.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby-cli\lib\create-cli.js
- C:\Users\USER\Downloads\freeCodeCamp\client\node_modules\gatsby-cli\lib\index.js

- Remove the "node_modules/sharp" directory, run "npm install" and look for errors
- Consult the installation documentation at https://sharp.pixelplumbing.com/en/stable/install/
- Search for this error at https://github.com/lovell/sharp/issues

⠋ load plugins
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @freecodecamp/client@1.0.0 develop: `node --inspect=0.0.0.0:9228 node_modules/gatsby-cli develop`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @freecodecamp/client@1.0.0 develop script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\USER\AppData\Roaming\npm-cache\_logs\2020-05-07T02_07_16_405Z-debug.log
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @freecodecamp/freecodecamp@0.0.1 develop:client: `cd ./client && npm run develop`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @freecodecamp/freecodecamp@0.0.1 develop:client script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\USER\AppData\Roaming\npm-cache\_logs\2020-05-07T02_07_16_475Z-debug.log
ERROR: "develop:client" exited with 1.
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @freecodecamp/freecodecamp@0.0.1 develop: `npm-run-all ensure-env -p develop:*`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @freecodecamp/freecodecamp@0.0.1 develop script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\USER\AppData\Roaming\npm-cache\_logs\2020-05-07T02_07_16_800Z-debug.log

Please help me out

I suggest you find and join the contributors gitter channel, it is there you can find help for this.


I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.

Note: Backticks are not single quotes.

1 Like

Try and cd into the client folder and run npm i from inside it. You may want to delete the node_modules folder (inside the client folder) first, or just the node_modules/sharp folder if it exists. If it is successful, cd back out to the root and run npm again.

I am having the same issue and tried the workaround above but I am still getting the same issue.

thanks I would try that

Im still having the same issues

I can’t help you, try the Contributors room on Gitter

1 Like