My portoflio HTML CSS class is not working

My portoflio HTML CSS class is not working
0

#1

Hi, I have problem with classes: “naw” nothing happens. Any ideas? Thank you. CSS is working other semantic tags work properly but this class not. thank you for your help.
HTML:

<html>
  <head>
    <link href="https://fonts.googleapis.com/css?family=Josefin+Sans:400,400i,600,600i,700,700i&amp;subset=latin-ext" rel="stylesheet">
  </head>
<body>
<header>
  Welcome to my portfolio
  </header>
  <naw>
    <div class="naw">
      dsa
    </div>
    </naw>
	
	
</body>
</html>

CSS:

body
{background-image:url(http://www.wallpapers4u.org/wp-content/forum/uploads/room_office_desk_chair_shelves_39161_1920x1080.jpg);
  font-family: 'Josefin Sans', sans-serif;
}
header
{font-size:60px;
  text-align:center;
 font-weight:700;
 color:#555;
  
}

.naw
{height:80px;
  width:100%;
  background color:#666567;
  
}

#2

What doesn’t work? The <div> with the naw class gets styled as expected.

There also isn’t a <naw> element. Maybe you meant <nav>?


#3

Hi szymon,
I copied your code on codepen.io. It’s a good place to experiment with changes before putting them in your project. is not a valid tag, like the other replier said. I believe the only issue is the background color for class=“naw”. It is not showing a background color because the attribute is background-color, not background color. I recommend using a text editor that will recognize the correct syntax of properties.


#4

I forgot hyphen between background and color. thank you all. I will do my project in text editor and I will copy all content to the pen. Thank once again