My Product landing page, any comments appreciated :)

My Product landing page, any comments appreciated :)
0

Here’s my product landing page. Any comments you might have would be great!
Cheers!
https://codepen.io/muustalu/pen/GRROwOP

1 Like
  1. I think you should format your navigation links (features, prices, links). Center them or put them to the right it looks weird where it is at the moment.

  2. The video is not working. Not sure if that is a problem on my end, (“Youtube refused to connect”)

  3. I think it would be cool if you add a hover state to the select buttons so they change color when the mouse hovers over them.

  4. I think you could center your footer links (privacy, terms, contact) and your copyright.

1 Like

Well done to get this completed!
My observations are the same as @Etra, plus I’d consider a more attractive color palette (but this is just a small thing).
Keep Going! I look forward to seeing your next project!

1 Like

You did a great job on the color, but there are a few thing you need to change:

  • First of all, right by the truck, headphone, and music note symbols, there is some text that seems to overlap some others.
  • You also need to get rid of the horizontal scroll. The three products are lined up and are exceeding the width of the page. try to place them closer together or to place them each on top of each other.
  • You have a fixed banner on top of the page, but it is there for no point–You should add some link buttons that enable the user to go to different parts of the page. If you don’t add the links, delete the code that makes the banner. You don’t want something to take up extra, uneeded space.
  • did you get the right video link? If it’s not my terrible internet interfering with the issue, please fix the video tag so that there is one embedded in the page.
1 Like

Thanks a lot guys! I got rid of the horizontal scroll and managed to get the YouTube video working. It was due to using watch instead of embed in the video URL.

Cheers Conner! I’m wondering if the overlap in the text is due to bad responsive coding on my part, because I’m not seeing the overlap.

Oh, maybe because the size of my tab is thinner than yours.
the width of the codepen display I use is less than 100% of my computer. That was the problem.
change the view to make all of the cod editors on the left hand side and you’ll see the problem. try to ix it from there.