Problem with page/html/body display not occupying full page

Problem with page/html/body display not occupying full page
0

#1

Hi!

As you can see below, the body is not using 100% of my html, but my header is.
This pose a problem when I want to put a line that goes across the page (see my footer): it only goes across the body, not the whole html, so the line appears short.

Also, my header is made with a table instead of a grid because for some reason it wasn’t displaying properly (maybe the same reason my body is displaying weirdly). Also, I can’t seem to fix my navigation bar to the top.

Let me know how I can improve that! Thanks!


#2

@eloiseboileau It seems you have not added bootstrap to your css, so your page doesn’t take the styles properly (that’s why your nav doesn’t fix to the top).


#3

And how would I do that? I’m a little bit overwhelmed by everything I learned, and I can’t seem to figure what step is missing!


#4

Look in the css part of your Pen there is a settings button (it is kind of a gear), you should click on that button and then in the window that appears go to the Quick-add section and display the options, there must be some options like bootstrap, foundation, and Animate.css, just click on bootstrap and that’s it.


#5

Wow! See that’s the kind of thing I didn’t fully process yet! Now that you’ve told me, I remember doing it for my Tribute Page but I would NEVER I’ve figured that one out! I feel very frustrated to have spend that much time trying to figure it out how to grid stuff… but thank you so much! :slight_smile: