Problem with XAMPP installation on my windows server desktop

Problem with XAMPP installation on my windows server desktop
0

#1

Hi guys I need ur help concerning this.I’ve actually changed the port of the server and disabled world wide web service properties but am still getting this error please I will appreciate it if I can get a quick response.Thanks guys


Localhost refused to connect error
#2

Base advice: Have you tried restarting your machine? The name of the process occupying port 80 is weird (“unable to open process”) implies that either you didn’t allow it through Windows Defender Firewall, or there might be another instance of the same process running.

Diagnostic help if the problem persists after restart: In the command prompt, this will show you whether port 80 is indeed being listened to:
netstat -an | find /i "listening"

If that is indeed the case, you can follow the advice on Stack Overflow which is the top link when you Google “how to tell which application is using a port”. Basically, that advice is: open an elevated Command Prompt (or PowerShell with Admin access in Windows 10) and type netstat -a -b


#3

PID 4 is the system process, do you have another server running?


#4

@vipatron thanks but I was even thinking maybe I can’t install Xampp on windows server


#5

I didn’t realize you meant you were using “windows server” as an OS. I thought you meant you were using your Windows desktop as a server. You may need to check the XAMPP for windows documentation about changing the port. Because it’s almost certain that port 80 would be claimed by the OS if it’s called “Windows Server”


#6

@lasjorg actually the system belongs to the company where I’m currently doing my I.T so I’m not sure if another server is running but it seems a colleague of mine using it before installed sharepoint server on it.How do I check if a server is running or not


#7

use “netstat -a -b” to identify which process is using which port (must be an elevated cmd prompt)


#8

check Xampp,do you mean their website


#9

I just checked and I don’t understand the mesage,this is my first time trying to install xampp and it’s giving me so much problem,I just need it to start learning my php.Any other way out please?


#10

If you were at home, I’d tell you to copy/paste the results of that command into the chat. Since you are at work, doing I.T. for a company, that would likely give them grounds to fire you. Can you make a virtual machine and set up Ubuntu there? That’s probably the easiest.


#11

internship as in not a full staff:grinning::grinning:


#12

I’m unable to copy the the result,the copy option isn’t working so let me try your second option using ubuntu but how do I set up a virtual machine


#13

Are you sure ISS is not running on this system?


https://www.devside.net/wamp-server/opening-up-port-80-for-apache-to-use-on-windows


#14

please how do I check is running


#15

I mean how do I check if ISS is running


#16

Do you mean IIS please


#17

Yes, I meant IIS, sorry.

I’m not sure i can provide you with any more help then already given in the links. You can use TCPView instead of netstat, and check the links for information on conflicting services etc.

Here is another very comprehensive list
https://community.apachefriends.org/f/viewtopic.php?f=16&t=69784

Not sure why it is complaining about port 80 if you change the listening port.

What version of Windows server are you running?


#18

Thanks,I think I have finally solve the port issue but there is a new problem :I am getting error message while trying to load my localhost . It says something like this;site can’t be reached,localhost refuse to connect.I also noticed something on my xampp which is a red mark on my apache server and I think this might be the problem


#19

I would be expecting your response sir


#20


Could this be the problem