Public profile timeline not showing anything

Public profile timeline not showing anything
0

#1

My public profile is not showing any data in my timeline.

I have it set to public for “my profile” and “my time line” in Privacy Settings. When I open my public profile in a window where I’m not signed into freecodecamp, it says, “No challenges have been completed yet.” However, I have completed some challenges and when I’m signed in, everything shows up.


#2

Have you checked your privacy settings? What do you mean when you say that when you’re signed in “everything shows up”.


#3

Hi! Thanks for replying.

I’m trying share my profile/timeline of completed challenges with a friend who isn’t on freecodecamp and may join. I’m trying to show her how far along–or not–I am because she wants to try to catch-up so we can both work together from the same point.

Yes, as mentioned, “I have it set to public for ‘my profile’ and ‘my time line’ in Privacy Settings.”

I meant that the challenges that I have completed do show up, are visible, in the timeline on my profile only while I’m signed into freecodecamp. When I sign out and try to view my profile, I get a message that says, “No challenges have been completed yet.”


#4

Btw, I do realize that I can just tell her where I’m at in the challenges instead of sending a link to my profile/timeline. That isn’t the problem–it’s just how I found the problem. (And it’s not a big problem. I just don’t understand it and find it odd).


#5

Is it possible that at some point you inadvertently created a second account and you are sharing the link to that account? It shouldn’t matter whether someone is logged in to FCC or not. I see the same for the account you linked whether I’m linked in or not and also see the same thing for my own account whether I’m logged in or not.


#6

I’m visiting the same url, logged in or not, so I don’t think so.

Screen shots of what I see:

Logged in:

Logged out:


#7

I was able to reproduce this on my own account. I fixed it by setting “My certificates” to public in my settings.


#8

I wonder what went wrong to cause it.

Thank you for figuring this out!