Radio Buttons Each of your two radio button elements should be nested in its own label element. Each of your label elements should have a closing tag

Radio Buttons Each of your two radio button elements should be nested in its own label element. Each of your label elements should have a closing tag
0

I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

See this post to find the backtick on your keyboard. The “preformatted text” tool in the editor (</>) will also add backticks around text.

Note: Backticks are not single quotes.

You still haven’t done this.

Thank you Ariel Leslie I pass this section.

<label for="indoor"><input id="indoor" type="radio" name="indoor-outdoor"> Indoor</label>
    <label for="outdoor"><input id="outdoor" type="radio" name="indoor-outdoor"> Outdoor</label><br> 
1 Like

Congratulations on figuring it out. Happy coding!

Hello Ariel Leslie,
Can you help me with this challenge?


  <input type="radio"name="indoor-outdoor"checked>Indoor</label>

  <input type="radio"name="indoor-outdoor">Outdoor</label>

  <input type="checkbox"name="personality"checked>Loving</label>

  <input type="checkbox"name="personality">Lazy</label>

  <input type="checkbox"name="personality">Energetic</label>

You have closing label tags, but no opening label tags.

I put the opening label tag it did not work I will try again.

Ariel Leslie, Still will not let me pass.


  <label><input type="radio"name="indoor-outdoor"checked>Indoor</label>

  <label><input type="radio"name="indoor-outdoor">Outdoor</label>

  <label><input type="checkbox"name="personality"checked>Loving</label>

  <label><input type="checkbox"name="personality">Lazy</label>

  <label><input type="checkbox"name="personality">Energetic</label>

I’m guessing that at least some of those inputs are supposed to have values. What do the failing tests say?

When I copied in your code, it worked for me. Try resetting your code and pasting in only the new lines you were supposed to add.

O K Great I will give it a try.
Thank you
Bob Smith

Your first radio button on your form should be checked by default.

Your first checkbox on your form should be checked by default.

Did it pass once you reset your code, as @JeremyLT suggested?

If I reset the code all lesson will be lost (error message) so I don’t want to do that I did try rewriting the code then submit and add the word( checked) after submission still no go.

Go ahead and reset the code. Then put in the code that works, as @JeremyLT suggested. It won’t be lost because it’s right here.

As you can see I am new to this thanks for holding my hand.

No worries. We all start somewhere.

OK Great it worked!!!

O K Great it worked
Thank you
Bob Smith!!!

1 Like

I’m glad you got it figured out. Happy coding!