[SOLVED] Progress (HTML5+CSS) completely lost

[SOLVED] Progress (HTML5+CSS) completely lost
0

#1

Hi there,

I’ve sent an e-mail to [email protected] with details, including screenshots, but I got just an auto-reply.

  • I’ve created an account yesterday on fCC (using an e-mail address),

  • I’ve completed the HTML5+CSS track (level [61].

  • I’ve switched computers, on the second computer after I’ve logged in the progress was [1]).

  • Going back to the initial computer, in the menu the entries was shown as incomplete, but on the main page they were marked as complete.

  • After refreshing the page the progress was shown again as [1].

I don’t want to redo the 61 topics.
Can someone investigate/correct the issue?

UUID: fccfbea9ec5-a0e9-4241-…-…

Best regards,
Andrei

[SOLVED]: Bug was fixed by @BerkeleyTrue, see description of the issue here: https://github.com/freeCodeCamp/freeCodeCamp/issues/16147#issuecomment-350880464


#2

What username did you log into freeCodeCamp with?


#3

I sign in with the e-mail address, not a username.

Link to profile is https://www.freecodecamp.org/fccfbea9ec5-a0e9-4241-a5a1-f1bb82c0f51b


#4

I am having the exact same problem. All of my progress was lost, and I was on “Use Spans for Inline Elements” within the Bootstrap section.

I also log in with my email.

fcc9c43256b-c0f2-43f4-b0e2-35a052bad443

Please let me know if it is better to start my own thread instead. Thanks.


#5

Hi,

I’m having the same problem, I did the first few topics, Html, CSS, Bootstrap, and jQuery and finished off my first project, the tribute page and when I logged back in, all my progress was gone.

help would be greatly appreciated.

Thanks Joel.


#6

Same issue here and no response from support, nor in this forum, all tha time the same answer again and again


#7

No one on the forum has access to help you, I’m afraid.

@quincylarson is this the usual account issue, or does this sound like a different problem to you?


#8

I think the issue occurs when you log in with a different device. I had no issue as long as I logged in on my computer but it seems that my progress was lost after I logged in with my phone to check the forum. Could this be possible? @JacksonBates


#9

Could it be it see the new device as a new account?


#10

If anyone can produce the steps that consistently allow us to reproduce the issue, it would be easier to investigate.

I’ve never been able to reproduce account deletion bugs, so I can’t speculate as to the cause.


#11

Well thanks anyways. Guess I’ll do them again. It will be good practice and help solidify everything.


#12

@JoelLM I had the same problem. How did you solve progress loss?

When I came back to the first device, and clicked in Freecodecamp logo in top-left corner, I was redirected to current progres (place where I finished), but all the history was lost :disappointed_relieved:


#13

There are two different types of saved progress for Free Code Camp: your profile and your browser cache. However, there is also a known issue that may be affecting your account (see below).

Your completed challenges are all saved to your account in the FCC database. You can see the list of completed challenges and also the last submitted solutions by looking at your profile page.

If your profile does not include your completed challenges, here is my troubleshooting advice:

  1. Double check that you used the same method to sign in. Try logging out and back in again with the original method. Attempting to sign in with a different method will sometimes create a duplicate account. (FCC is taking steps to prevent this from happening in the future.)
  2. Double check that you aren’t on the beta site now and that you didn’t create your original account on the beta site by accident. (Yes, this does happen.)

Your progress tracking (map) is saved in your browser’s local storage. In-progress code is also saved in your local browser cache. If you are changing browsers or clearing your cache regularly you’ll have to use freecodecamp.com/map to navigate to your next challenge. Especially as you get to more complicated challenges that may take multiple sessions, I strongly recommend saving your in-progress work outside of the browser cache. This is a good opportunity to learn the ins and outs of your GitHub account, but you can also just save locally or use a service like repl.it which allows for versioning.

Known issue:

If your former progress cannot be found on your profile page, and your score has reset to 1, you have been affected by a known, but rare, issue. The team is working to resolve this issue.

If you want to start again, remember only the beginner and intermediate algorithms (marked on the map with a *), and the projects, are required to attain the front end certificate. Since your projects are likely hosted on Codepen, Surge or GitHub Pages, they have not been lost due to this reset - you can just resubmit them. Your algorithm solutions are the only critical solutions hosted directly on freeCodeCamp, so as you work on these be sure to push them to your GitHib repo, or store them with a service like Codepen, JSFiddle or Repl.

We’re sorry for the inconvenience and we are working hard to resolve future issues.


#14

@crazylittlepolka Your progress is only superficially lost. Go back and just resubmit all your lessons using the keyboard short cut. The work you did should still be there just the indicators on the map are gone. You should be able to get back to where you need to be in no time.


#15

Thanks to the work of @BerkeleyTrue, @raisedadead and @QuincyLarson this bug should now be fixed!

If you encounter this issue again, please post in the support category.

Thanks to all for their patience during this troublesome bug :slight_smile:

Happy coding!


#16

Thank you for your help :slight_smile:


#18

I just came across with the same issue, I’m better off and delete my account and save the inconvenience and frustration.
Thanks anyway.


#19

My progress was completely lost as well. I have been trying for months to figure this out. I emailed a while back. if I look for my profile it’s still there. I see my progress and everything.

When I log in it shows an empty curriculum and my user name is set to a uuid. If I change it to my user name, this one, it says it’s already in use. I tried every method I could think of to relink my old account. Nothing works. I wish I could see which email I used.