Twitch not letting me link to Profiles?

Twitch not letting me link to Profiles?
0

#1

Hey guys I’m having issues with my twitch. tv streamer and i’m trying to link to the users profile but the issue is that I set it up properly and everything but twitch is not letting me do that-here’s how i know-currently in the pen the FCC image is a link to google but before when i was working on it i had the exact same code but with the FCC account instead of google and it worked with google but not twitch and by the way when I copied the FCC link into the search bar it pulled up exactly what I wanted but it would not load when i try to link it from my pen. Thanks.


#2

Below is your link to google:

<a href="https://www.google.com/" target="_blank"><p id="freecodecamp" class="gamername"></p></a>

There is not FCC image in this link. You have a p element inside the a tags instead of an image. If the FCC image was a link to google, it would look something like:

<a href="https://www.google.com/" target="_blank">
<img class="gamerlogo" id="freecodecampimg" src="https://static-cdn.jtvnw.net/jtv_user_pictures/freecodecamp-profile_image-d9514f2df0962329-300x300.png">
</a>

#3

Im sorry it was linked to the image at first although i see what you mean but im afraid that does not solve my issue


#4

What’s the exact issue, then? Is the screen black when you click on a twitch link? If that’s the issue, it’s normal. Twitch seems to not allow linking from an iframe anymore (which codepen is), but the new (beta) Twitch apparently does.

Change your links to https://go.twitch.tv/channel_name and they should work fine.

Edit: also, there’s no <image> tag, if you need to have an image and a link, just wrap the <img> in <a> like @RandellDawson showed you.


#5

Yeah the screen turns white when opened and I kept trying the link given to me in the console but thanks for the new link it worked.