Unsplash images not rendering on freecodecamp/news

Unsplash images not rendering on freecodecamp/news
0

@QuincyLarson I’ve notice a bug in the way some images are rendered on the freecodcamp.org/news front page when viewed via Firefox mobile browser on an Android phone. Not urgent, but possibly worth investigating.

It happened on my last post and yours (I’m assuming you used the unsplash image feature of the ghost editor, too?)

Firefox Mobile:

Desktop Chrome:

This doesn’t effect the default browser that ships with Samsung phones, just ff as far as I can tell.

Oh, hilarious. I forgot I made a sockpuppet account for testing stuff. Oh well. I confirm this is actually me :slight_smile:

Hi Jackson,

Thanks - that is a strange bug indeed. Can you confirm that only Unsplash-based cover images are affected?

It’s just a hunch. I’ll check next time I’m at a computer.

Hi Jackson, were you ever able to confirm this?

I had forgotten to check, but looking now I can see that the problem also appears to affect the Firefox desktop browser as well.

Chrome

Firefox

The images have this attribute onerror="this.style.display='none'" which is obviously why they are not showing, but I can’t see an obvious reason why the images trigger an error in FF and not in Chrome.

According to the dev tools network tab it’s not even attempting to download the image.

@QuincyLarson

ACTUALLY, the problem on FF is just that I have Privacy Badger installed and it is blocking requests to Unsplash!

And I just checked my phone browser and that also has PB blocking Unsplash.

Curse my privacy paranoia!

PEBCAK

OK - thanks for confirming. I’m surprised Privacy Badger is blocking unsplash. I just messaged both Unsplash and Privacy Badger about this to see if they can fix this.

1 Like